hapus user expired otomatis Hotspot userman

Penyedia layanan hotspot dengan voucer userman tentu terkadang harus menghapus user yang sudah expired supaya tidak menuh menuhin database usermannya , hal ini tentunya akan menyulitkan kalo dihapus secara manual , karena secara berkala kita direpotkan harus menghapusnya ( untuk yang ingin menghapus manual bisa baca artikel sebelumnya : hapus expired userman.

Pada kali ini saya akan berbagi bagaimana caranya supaya bisa menghapus otomatis hapus user expired otomatis Hotspot userman tersebut secara terjadwal

langkah pertama masuk ke winbox ke menu system script tambahkan kode berikut dan beri nama hapus_userman : /tool user-manager user remove [find where !actual-profile]

atau dengan perintah berikut di terminal :

/system script add name=hapus_userman source= “/tool user-manager user remove [find where !actual-profile]”

Catatan :  tanda petik sebelum dan sesudah perintah /tool user biasanya akan hilang kalo hanya copy paste , tuliskan secara manual.

dan jadinya seperti ini :

untitled

 

 

setelah sukses seperti diatas selanjutnya ke menu system scheduler

tambahkan nama hapus userman seperti contoh berikut :

Info dahsyat

untitledKeterangan diatas adalah script akan run pada pukul 02 dini hari mulai tanggal 15feb 18 dan akan berulah setiap 1hari , jadi esok hari akan mengulang script tersebut tepat pada pukul 2 dini hari setiap hari .

buat penjadwalan berulang misal pukul 02.00 lalu 02.30 lalu 03.00 dst karena satu kali run mikrotik tidak menghapus semua user expired , hasilnya seperti berikut :

untitled

 

atau dengan perintah berikut di terminal :

/system scheduler add interval=1d name=hapus_userman0 on-event=hapus_userman start-date=Feb/18/2018 start-time=02:00:00
/system scheduler add interval=1d name=hapus_userman1 on-event=hapus_userman start-date=Feb/18/2018 start-time=02:30:00
/system scheduler add interval=1d name=hapus_userman2 on-event=hapus_userman start-date=Feb/18/2018 start-time=03:00:00
/system scheduler add interval=1d name=hapus_userman3 on-event=hapus_userman start-date=Feb/18/2018 start-time=03:30:00

 

Sudah work di mikrotik versi v6.27

Tutorial Video Youtube :

Semoga bermanfaat

 

Add a Comment

Alamat surel Anda tidak akan dipublikasikan.